Resolved
The Upstream maintenance are over. Everything should be working properly again.
Identified
We are currently experiencing intermittent timeouts and degraded performance across some of our services.
This is caused by ongoing network maintenance from our upstream provider, which may result in packet loss and reduced bandwidth. As a result, some requests may be slower than usual or temporarily fail.
We are actively monitoring the situation and expect performance to improve as network conditions stabilize.